[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Nicotine (p2p client) crashes (too many open files ??)


I am not able to use nicotine, the soulseek client. The program
starts up, I am able to configure the program by way of the gui and
log in to the network. When I enter a search, the program does
nothing (apparently) for 5 to 10 seconds and then crashes with the
following error message:

 WARNING **: Cannot open font file for font Andale Mono 4
 WARNING **: Cannot open fallback font, nothing to do

I run a daily updated unstable system and I believe I have the
latest and greatest of GTK and Python.

I ran strace and found a couple of messages that might be related to
the problem. 

There are quite a number of messages like this:
stat64("/usr/share/locale/en_US/LC_MESSAGES/nicotine.mo",0xbfffb820) = -1 ENOENT (No such file or directory)

$ grep ENOENT trace.txt | wc -l

And just before the program exits:
open("/usr/share/fonts/truetype/Andale_Mono.ttf", O_RDONLY) = -1 EMFILE (Too many open files)

I am not sure these messages are the cause of the problem or just an

Any hints to look into this issue or solve it are welcome.


Reply to: