[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: named complaining about lame servers when resolving

Jacob Anawalt wrote:

Malcolm Ferguson wrote:


I've tried to configure bind on my Woody box as a caching DNS server for a segment of the network. However, after mistyping an IP address that I was trying to resolve elsewhere I'm now getting lots of messages in the log file complaining about a lame server. Have I misconfigured named, or is this an error I can ignore? If the latter, how do I make the problem go away - restart the daemon?

Bind 9.1 (bind9_1:9.2.1-2.woody.1_i386)

Error message (repeated over and over):

Sep 22 17:12:00 ns1 named[12680]: lame server resolving '' (in '1.5.198.in-addr.arpa'?):

Are you recieving SMTP or other external traffic with a service that may be trying to resolve IP addresses to names? The IP belongs in a block assigned to UUNET Technologies, Inc. but doesn't appear to have a reverse dns record available. It also doesn't respond to ping's. If you know you don't want to deal with that address, you could drop all packets to/from it with iptables.

No traffic. I just did a bad type-o when doing an nslookup on another box. Ever since I've been getting these messages from bind. Maybe I need to give more details, although I didn't think the rest was relevant:

This is a Win2K network running Active Directory. and are the domain controllers, and are the nameservers for all of the Win2K boxes on the network. They are configured to forward non- requests to two Debian boxes that have external connectivity and do some DNS caching. Those same boxes either forward to external nameservers, or in the case of, back to the Win2K DNS servers.

So, I did a DNS lookup on a Win2K box of that 196.5.1 address, which went to either or Those servers forwarded the request to the Debian boxes, who presumably tried to forward it to the external DNS servers. Ever since though, both of them have been logging messages about the lame server.

Now, it's perfectly possible that I've misconfigured the names servers, or that I'm not understanding how DNS works as I'm pretty new to this.


Reply to: