[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: nforce kernel modules

 --- "Jamin W. Collins" <jcollins@asgardsrealm.net> escribió: 
> > That's not it, I have alsa-base and alsa-utils installed.
> That's very odd, the init script should store your settings in the
> following section:
>             if [ "$alsactl_store_on_shutdown" = "true" ]; then
>                 printf "Storing ALSA mixer settings ... "
>                 if alsactl store > /dev/null 2>&1; then
>                     sleep 1
>                     echo "done."
>                 else
>                     echo "failed"
>                 fi
>             fi

Right.  I always get an echo of failed (during boot and shutdown).

> The control variable $alsactl_store_on_shutdown is set to true at the
> beginning of the script and then read from /etc/defaults/alsa.  You
> might check to see if it's set to something other than 'true' in
> /etc/defaults/alsa.  Beyond that, you could execute the init script via
> "sh -x" so all commands are echo'd as they are executed.  This might
> give an idea of why alsactl isn't storing the settings.

Set to true.

> Do you by chance have two alsa config files in /etc/modutils?

Nope.  Just one, a symlink to /etc/alsa/modutils/0.9

> > But why does this only occur on one machine?  Both run 2.6.0-test2 on
> > Sid. Is it differences in the driver?
> Some sound cards have multiple dsp output devices, the yamaha chip in
> the laptop just might.  An strace of audacity's startup might give some
> information.  Other than that I really don't know.

I'll have to run that down tomorrow when I am awake :-)


Yahoo! Messenger - Nueva versión GRATIS
Super Webcam, voz, caritas animadas, y más...

Reply to: