[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

audio problem (alsa emu10k1 woody 2.4.21custom)

when I run xmms, on some mp3s, at the end, the last tenth of a second is repeated a multiple of 7 times (usually 14 times, but sometimes 7, 21, or 28). Many other programs display a similar problem, lletters is the simplest program I could find that consistantly shows the issue, it repeats every ~.5 second exactly 7 times all the way through.  When I run strace lletters, while it is repeating, the last line I get is:
write(8, "\177\177\177\177~~\177\177\177\177~~\177\177\177\177\177"..., 4096
and when it jumps to the next section and begins repeating, it prints:
) = -1 EIO (Input/output error)
ioctl(8, SNDCTL_DSP_GETOPTR, 0x804d168) = 0
[TIME: 00:00:00])      = 17]", 17
read(7, "\177\177\177\177\177\177\177\177\177\177\177\177\177\177"..., 4096) = 4096
write(8, "\177\177\177\177\177\177\177\177\177\177\177\177\177\177"..., 4096) = 4096
(it repeats the ioctl, read, write pattern 7 times successfully before the next EIO)
I installed libc6-dbg, compiled lletters  and ran export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib/debug ; gdb ./lletters
while it is repeating, it is indeed inside __libc_write(), but the list command does not work, even after getting the source to libc6-dbg, unpacking the sub-files and addi
ng every sub-directory with the dir command in gdb.
(gdb says:
0x40441404 in __libc_write () at __libc_write:-1
-1	__libc_write: No such file or directory.
If I set a breakpoint at play_file and next through the execution, it does not repeat in the middle and only sometimes at the end, when it calls __libc_close (like xmms does except it always repeats 7 times if it happens)

that's where I'm stuck.  Have I obviously screwed something up?  If not, how do I get the list command to work while i'm in libc6?  Or is there a better plan of attack?

I have the following packages installed that are unavailable or at a different version with an official only (plus security) sources.list:
alsa-base Version: 0.9.2-7
alsa-modules-2.4.20alsa Version: 0.9+0beta12+3+p0+10.00.Custom
alsa-modules-2.4.20jj.ker Version: 0.9.2-7+10.00.Custom
alsa-modules-2.4.21jj.ker Version: 0.9.2-7+10.00.Custom
alsa-source Version: 0.9.2-7
kernel-headers-2.4.20alsa Version: 10.00.Custom
kernel-headers-2.4.20jj.ker Version: 10.00.Custom
kernel-image-2.4.20alsa Version: 10.00.Custom
kernel-image-2.4.20jj.ker Version: 10.00.Custom
kernel-image-2.4.21jj.ker Version: 10.00.Custom
lame-extras Version: 3.93-0.0.1
lame Version: 3.93-0.0.1
libkmid Version: 4:2.2.2-13.woody.7
liblame0 Version: 3.93.1-woody0.0
liblame-dev Version: 3.93.1-woody0.0
libusb-0.1-4 Version: 1:0.1.6a-2.1
libwine-alsa Version: 0.0.20030115-1.bunk
libwine-print Version: 0.0.20030115-1.bunk
libwine Version: 0.0.20030115-1.bunk
nvidia-glx-dev Version: 1.0.2880-3
nvidia-glx Version: 1.0.2880-3
nvidia-kernel-2.4.20alsa Version: 1.0.2880-1+10.00.Custom
nvidia-kernel-2.4.20jj.ker Version: 1.0.2880-1+10.00.Custom
nvidia-kernel-2.4.21jj.ker Version: 1.0.2880-1+10.00.Custom
nvidia-kernel-2.4.21-rc8jj.ker Version: 1.0.2880-1+10.00.Custom
wine-doc Version: 0.0.20030115-1.bunk
wine-utils Version: 0.0.20030115-1.bunk
wine Version: 0.0.20030115-1.bunk

Need a new email address that people can remember
Check out the new EudoraMail at

Reply to: