[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: aptitude and /etc/lilo.conf

J F wrote:
Rob Weir wrote:

On Mon, Jul 28, 2003 at 06:42:47PM -0700, J F wrote:

Based on the output from aptitude and my current
lilo.conf, do you think I need to do anything to lilo.conf?

aptitude is just a frontend.  dpkg is doing the actual work of unpacking
and installing the package.

Is aptitude going to put the new kernel
in /boot?

dpkg will, yes.

Will aptitude fix the link /vmlinuz ?

dpkg will. yes.

I ran aptitude and it did a lot of things and then said:
aptitude wrote:

Unpacking kernel-image-2.4.20-3-386 (from .../kernel-image-2.4.20-3-386_2.4.20-9_i386.deb) ...

You are attempting to install an initrd kernel image (version 2.4.20-3-386)
This will not work unless you have configured your boot loader to use
initrd. (An initrd image is a kernel image that expects to use an INITial
Ram Disk to mount a minimal root file system into RAM and use that for
As a reminder, in order to configure lilo, you need to
add an 'initrd=/initrd.img' to the image=/vmlinuz
stanza of your /etc/lilo.conf
I repeat, You need to configure your boot loader. If you have already done
so, and you wish to get rid of this message, please put
`do_initrd = Yes'
in /etc/kernel-img.conf. Note that this is optional, but if you do not,
you'll continue to see this message whenever you install a kernel
image using initrd.
Do you want to stop now? [Y/n]

#       restricted
#       alias=1

The kernel image will be unpacked into /boot as
vmlinuz-<kernel-version>, and a symlink called /vmlinuz will be created
pointing to it.  This was in the default lilo.conf, but you deleted it.
You'll need to recreate a stanza along the lines of:


For kernels from kernel-image packages to work.  You won't need to
modify it again, though.  You might want to make it the default.

# ls -ld /v*
drwxr-xr-x   16 root     root         4096 Jan 18  2003 /var
lrwxrwxrwx 1 root root 23 May 21 12:23 /vmlinuz -> boot/vmlinuz-2.4.20-xfs

Oh, you have that link?  Why did you modify your lilo.conf, then?

Thanks for answering.  I was beginning to think I would not
get an answer to that question.
I didn't modify lilo.conf or the /vmlinuz links.
I can only assume that either this is the default from the knoppix
hard disk install or it got downloaded when I did an apt-get upgrade.

Thanks again,
I'll try to add that stanza and then lilo to get past this upgrade issue.

Your suggestion worked:

root@a1700xp:/etc# diff lilo.conf.orig  lilo.conf
< vga=791
> #vga=791
< image=/boot/vmlinuz-2.4.20-xfs
> image=/vmlinuz
<       initrd=/boot/initrd.gz
>       initrd=/initrd.img
> image=/boot/vmlinuz-2.4.20-xfs
>       label=L2.4.20x
>       initrd=/boot/initrd.gz
>       read-only
> #     restricted
> #     alias=2
< #     alias=2
> #     alias=3
< #     alias=3
> #     alias=4

The diff doesn't show it clearly but
maybe this is clearer:

#       restricted
#       alias=1

And make sure these links are here:
# ls -l /v*
lrwxrwxrwx    1 root     root           25 Aug  3 12:32 /vmlinuz -> boot/vmlinuz-2.4.20-3-386
lrwxrwxrwx    1 root     root           23 May 21 12:23 /vmlinuz.old -> boot/vmlinuz-2.4.20-xfs

Thanks to Rob Weir.

Reply to: