[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RealTek 8139 Problems

Robert Tilley wrote:
When I installed my system with the Debian 3.0 CD, kernel 2.2.0 was installed. I selected to install the RealTek 8139 drivers and my NIC has been functioning perfectly.

I've attempted to install 2.4.19, 2.4.21, and 2.6.0-test2. During a menuconfig, I specify the RealTek 8139 drivers to be installed as part of the kernel. However, when I reboot into the fresh kernel my NIC is undetected and I have no internet access. I must reboot into 2.2.0 if my NIC is to be used. I've even gone so far as to install _all_ RealTek drivers and no luck.

Any ideas?

Comments are most appreciated,

Robert Tilley

On my machine the older rtl8139.o "realtek driver" module worked just fine with the 2.2.XX series, and the more recent 8139too.o "realtek driver" module also worked. I normally used the older driver because I was used to it & it worked. When the 2.4.XX kernels came out the older driver module (rtl8139.o) didn't seem to be available and I had to switch to the 8139too.o module. The need for this switch was not immediately apparent, except I couldn't get my network going with the new kernel... a sympto similar to yours.

You might check which module you are trying to load in the 2.4.XX kernel series mentioned and make sure it is the more recent 8139too.o module. The places to check are in your /etc/modules file and in modconf.

-Don Spoon-

Reply to: