[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: my treo won't sync

> i've tried both pilot-xfer (from pilot-link) and kpilot. neither recongizes
> it. my visor platinum works fine. there is the minor problem of the usb
> char dev not showing up til you hit the button. if i run pilot-xfer right
> after hitting the sync button, it works for the visor. treo just isn't
> seen.
> does anyone have any tips? this is a treo 90.

The Treo 90 works fine for me on Sid. Here's a checklist of items.

modules must be loaded
  2.4.x kernels: usbcore, usb-uhci, usbserial, visor
  2.6.x kernels: usbcore, uhci-hcd, usbserial, visor

  /dev/pilot (or whatever you like) linked to
  /dev/ttyUSB1 (not ttyUSB0 !)

  root:dialout owns /dev/ttyUSB1
  make sure you're a member of group dialout
  and the group can write to both ttyUSB0 and ttyUSB1

kpilot (or other program)
  configure to use /dev/pilot (or whatever you configured above)

  load all modules manually (auto config/load covered below)
  plug in hotsync cable to computer and Treo
  start kpilot (or other program)
  push hotsync button on cable
  everything should work!

auto configuring/module loading
    /etc/usbmgr/vendor/082d/* is for handspring
    /etc/usbmgr/vendor/082d/0100/* is for some older model
    mkdir /etc/usbmgr/vendor/082d/0200 for treo
    cp contents of .../0100 to .../0200
    edit /etc/usbmgr/usbmgr.conf
    search for visor
    copy line "vendor 0x82d product 0x100 module usbserial, visor"
    and edit the copy to "vendor 0x82d product 0x200 module usbserial, visor"
    usbmgr will now auto load the modules when the
     hotsync button is pressed
    I haven't gotten hotplug figured out, but if you know how it works 
    (I don't yet) it should follow from the above info


Reply to: