[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sandisk sddr-75 CF/SM usb reader problems [solved]

it works!!!  Thank you so much Neal, thank you, thank you, thank you.  I
had given up hope. :)

On Wed, Jul 30, 2003, Neal Lippman wrote:
> OK, here's what I notice: in /dev, your /dev/sd* device entries are
> correctly set up with block major device number 8, as is the case for
> the first (I think) 33 scsi disk devices.
> The output of /proc/devices, however, does not show that you have a
> block major device 8 entry, which should show the "sd" driver.
> My system's output for the same two commands does indeed show block
> major 8 as a device in /proc/devices, with sd as the driver - so I would
> surmise that this is your problem and why the devices don't seem to
> exist. When you try to mount /dev/sda1, the kernel should be looking
> for  driver registered to handled block major 8, but there isn't one.
> A harder question is WHY you don't have one. On my system, it appears
> that scsi disk support is built into the kernel - because I haven't
> loaded sd.o as a module and no such module appears in
> /lib/modules/2.4.18.../kernel/drivers/scsi.

I couldn't find an sd.o anywhere but browsing around in
/lib/modules/2.4.21.../kernel/drivers/scsi , I saw sd_mod.o . I tried
`modprobe sd_mod`, now I can use the reader. :)  I've added sd_mod to
/etc/modules.  I guess the kernel I was using last year when I had no
troubles with my camera must have had this compiled in; I don't
remember changing /etc/modules at all.

> You need to verify that on your system, with whatever kernel you are
> running, that either a) scsi disk support is compiled into the kernel,
> or b) if it is built as a module, you are loading the module (eg by
> putting this entry into /etc/modules or by whatever other mechanism you
> prefer.
> While the kernel does dynamically locate and load some modules as needed
> based on system calls, I don't know if the scsi subsystem or mount
> subsystem does that for the scsi disk drivers; maybe someone on the list
> has delved into that aspect of the kernel code and can help here. My
> guess would be "no".

Thank you again, it's really made my day to get this finally working. 


Just in case someone with similar trouble reads this in the future, the
necessary modules appear to be:

usb-uhci (or I guess usb-ohci or usb_ehci depending on the motherboard)

the output of `mount` should show:
none on /proc/bus/usb type usbdevfs (rw)

/dev/sg0  /dev/scd0
/dev/sg1  /dev/sda   (this particular reader has 2 slots)
/dev/sg2  /dev/sdb

# cat /proc/devices 
Character devices:
  1 mem
  2 pty/m%d
  3 pty/s%d
  4 tts/%d
  5 cua/%d
  6 lp
  7 vcs
 10 misc
 14 sound
 21 sg
 29 fb
128 ptm
136 pts/%d
162 raw
180 usb
226 drm

Block devices:
  1 ramdisk
  3 ide0
  8 sd
 11 sr
 22 ide1
 65 sd
 66 sd

Reply to: