[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: corrupted dpkg?

Sridhar Srinivasan wrote:

Kent West wrote:

I'm no expert, but what I'd try is to find the mozilla-xft.deb and liblocal-gettext....deb files, perhaps in /var/cache/apt/archives, and try installing them manually with "dpkg -i libloc....deb".

I tried that for other files. Results in the following. The same error occurs no matter which package I try to install. I think i need to go into some file and either delete or modify the entry for mozilla but I'm not able to figure out which file it is.

degoba:/var/cache/apt/archives# dpkg -i libtext-iconv-perl_1.2-2_i386.deb
Selecting previously deselected package libtext-iconv-perl.
(Reading database ...
dpkg: serious warning: files list file for package `mozilla-xft' missing, assuming package has no files currently installed.
dpkg: error processing libtext-iconv-perl_1.2-2_i386.deb (--install):
files list file for package `mozilla' contains empty filename
Errors were encountered while processing:
Processing was halted because there were too many errors.

So you're saying you tried the package-specific "dpkg -i mozilla-xft" and it fails (because this is the package that seems to be causing the problem)? If so, I'd try to uninstall it with "dpkg --purge --remove mozilla-xft", and then try reinstalling it with "apt-get install mozilla-xft".

If that doesn't work, there's some files, I believe in /var/lib/dpkg, that might be causing the grief. I don't know which files do what, but I'd start with renaming "status" to something like "status.bak" and then try "apt-get update" and "apt-get install mozilla-xft". If that doesn't do it, I'd try other files (or search Google/Debian-User archives for the correct answer instead of trial-and-error, or wait for some more authoritative answer from this list).

I had a similar problem about two years ago, so you might search the archives of about that time for my name and something like "dpkg". But that memory is very hazy.


Reply to: