[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: tasksel, first time with debian

On Tue, 2003-07-01 at 02:21, Bob Proulx wrote:
> Iain Buchanan wrote:
> > Depends: <package> but it is not going to be installed and then finally
> > E: Sorry, broken packages
> > for anything I try through tasksel.
> That looks like a broken /etc/apt/sources.list file.  Which may have
> happened if you edited the file and made a typo or possibly if you had
> a problem with the web proxy section.  Check /etc/apt/* for anything
> which looks suspicious.

All thats in /etc/apt is apt.conf.d/70debconf and sources.list. 
70debconf contains:
// Pre-configure all packages with debconf before they are installed.
// If you don't like it, comment it out.
DPkg::Pre-Install-Pkgs {"/usr/sbin/dpkg-preconfigure --apt || true";};

> > I'm using 3.0r1 on and athlon XP 2000+ with pretty standard hw.  I've
> > got to the shell, and got the network going, but I can't get a gui!
> In the US?

No, Australia, and the locations in sources.list all come from

>   Here is a US centric example /etc/apt/sources.list file
> for Debian stable with security updates.
> I actually don't use tasksel any more myself.  I just install the
> packages I want.  Here is a hint which might be of use to you.  Run
> 'tasksel -t' which does not actually run the command but just prints
> out the apt-get command that it would have run without the -t option.

I tried that just for X window system:
# tasksel -t
apt-get install x-window-system

and then I tried running that apt-get command but I get another
dependancy error.  I was kinda hoping it would download and install deps
as needed.  If I try and solve them myself by adding more packages to
apt-get install, I just run into cyclic version problems...

Iain Buchanan <iaindb@bigpond.com>

Reply to: