[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't boot anything....



On 24 Jun 2003, Alex Malinovich wrote:

>On Tue, 2003-06-24 at 06:28, Kjetil Kjernsmo wrote:
>> Dear all,
>--snip--
>> So, it seems if I have the whole boot sequence, it first tries to boot
>> from floppy, decides it is nothing in there (though it is), then tries to
>> boot from CD, decides it is nothing in there (though a perfectly fine
>> Knoppix CD is there), and then goes on to boot from HD, but that ends up
>> printing "01 01 01 " etc....
>> 
>> Am I fscked....? 
>
>I agree with the other replies in that it SOUNDS like a hardware
>problem. 

Yup, and thanks to everybody!

>Then again, I can SOUND like a duck, but that doesn't make me a
>duck. :)

Hehe! :-) 

>Here's my concern. The computer is actually "booting fine" from the HD.

Huh? ;-)

>In a manner of speaking.

OK! :-)

> The 01's that are being printed to the screen
>are coming from lilo, so the HD is actually booting. 

That's very interesting. 


>The first, and
>easiest, thing to check is your BIOS settings. Rather than disabling all
>of the other boot devices, try leaving them all enabled but just
>changing the boot order. Preferably as:
>
>1. Floppy
>2. CD-ROM
>3. HD

That's my default, actually. I'm using that normally.

>Also, since you've been messing with APM, I'd suggest the following.
>Shut down the computer, unplug EVERYTHING from the back (including
>power), push the power button to let it drain out whatever is left, and
>then let it sit for a few minutes. Then plug everything back in and boot
>it up. I've had a problem with my computer going into power saving mode,
>and not coming out of it even after repeated hard resets and powering
>down. The only thing that worked was the above.

Hm, that is also very interesting. Before having read what you wrote, I
did unplug everything while at work yesterday, cleaned out some dust (it
was a lot in there, my previous office had wall-to-wall carpets), and went
over internal IDE cables to check that they were well connected. Now, it
boots consistently from floppy, specifically tomsrtbt. 

I went over the HD, and it seems nothing is lost there, and all partitions
mounted fine. 

>If you have some extra free time, it would also be a good idea to strip
>down the system as was mentioned in another post. 

Yup.

>Try booting from one of your floppies. Or all of your floppies for that
>matter. You might also want to try booting from a floppy that ISN'T a
>boot floppy just to make sure you get an "Invalid System Disk" error so
>you know everything is working more or less ok.

Yeah, I tried that the other day, before posting. Neither error message
nor boot. But now, a disk with tomsrtbt runs fine, as I said. 

>If you still can't boot after this, try booting from the CD-ROM. If your
>Knoppix CD doesn't work, try some other bootable CD-ROMs. 

Yeah, I'll try to get one burnt. The Knoppix CD was needed for advocacy
efforts anyway, so I gave it away... :-) 

>Finally, if/when you manage to get the system booting, then find a good
>Linux boot disk (Knoppix CD, boot floppy, etc), and re-run lilo.

Yeah, I reinstalled the kernel that was working before this happened last
night, but it didn't make any difference. 

However, and I think this is a lead:

On installation of the new kernel, it complains about "/boot/mbr.b" and
tells me to install the mbr package. I don't remember the exact wording,
but I guess the wizards who wrote it will recognize... :-) This was the
stuff I didn't understand the last time around. However, dpkg -l says that
I _have_ mbr installed, so perhaps something has happened to just my MBR?
It is particulary interesting since you mention that the "01 "'s are
coming from LILO. 

Does this mean anything to you....?  

Obviously, I'll have to clean out some more dust and go over my system,
but perhaps that is only making it unstable, not really broken... 

Cheers,

Kjetil
-- 
Kjetil Kjernsmo
Recent astrophysics graduate                  Problems worthy of attack
University of Oslo, Norway            Prove their worth by hitting back
E-mail: kjetikj@astro.uio.no                                - Piet Hein
Homepage <URL:http://folk.uio.no/kjetikj/>
Webmaster@skepsis.no                            OpenPGP KeyID: 6A6A0BBC



Reply to: