[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Help running remote X app



Hi all
I'm unable to get an app (say xterm) on a 'remote' machine (i.e. my laptop
on desk next to me) to appear on my local display - both debian unstable
-one running gdm and all the gnome2 stuff, the laptop xdm and miminimlist
xwindow environment.

Based on some reading and previous posts here, I've tried
*xhost + (apparently not relavent any more, but has helped in past)
* I've removed --no-listen tcp from /etc/X11/xinit/xserverrc
* I've tried 'merging' xauth cookies - while I don't understand the whole
xauth thing - xauth list at either end shows references to other end
* apparently ssh makes xauth not applicable, so tried as below with ssh
-X, but also with out -X and rsh and telnet. Also put ForwardX11 yes in
~/.ssh/ssh_config under name of other host at each end.

glenn@odin:~$ ssh -X thinkpad
glenn@thinkpad's password:
Login stuff bla bla bla
glenn@thinkpad:~$ export DISPLAY=odin:0
glenn@thinkpad:~$ xterm
xterm Xt error: Can't open display: odin:0
glenn@thinkpad:~$


Any help greatly appreciated,
Thanks
Glenn



Reply to: