[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: sound: loading of sound driver fails after reboot from Windows

On 10 Jun 2003 "D." <youto_22554@yahoo.com> wrote:

>> >> --- Ben Kal <benkal@euronet.nl> wrote: Hi folks,
>> >> 
>> >> Do some of you know more about the following inconvenience I have with
>> >> sound on my Linux machine:
>> >>   sound works fine if I boot directly into Linux after power-on,
>> >>                and if I reboot from Linux back into Linux;
>> >>   sound does not work at all after rebooting into Linux from Windows.
>> >> In Windows sound works under all circumstances.


> Since this is the first that I saw this, have you tried to add your sound
> driver to /etc/modules . In my /etc/modules I have ac97_codec, soundcore,
> pci-scan, tulip all on their own line. That causes those modules to load
> at boot up. HTH Don

Just tried it, but as I already expected, this is no cure.

Look, the problem is not that Linux does not try to load module ymfpci:
it tries very hard! I find dozens of failed attempts reported in
/var/log/syslog and /var/log/messages, from the very start of the boot
sequence, when the hotplug subsystem loads drivers for all devices present.
The problem is that, with ymfpci, every attempt fails with the following
sequence of messages, which is also the result of entering 'modprobe ymfpci'
on the command line:

PCI: Found IRQ 9 for device 00:09.0

ymfpci: YMF744 at 0xfedf8000 IRQ 9

/lib/modules/2.4.20-hetkukel-1/kernel/drivers/sound/ymfpci.o: init_module: No such device

/lib/modules/2.4.20-hetkukel-1/kernel/drivers/sound/ymfpci.o: insmod /lib/modules/2.4.20-hetkukel-1/kernel/drivers/sound/ymfpci.o failed

/lib/modules/2.4.20-hetkukel-1/kernel/drivers/sound/ymfpci.o: insmod ymfpci failed

Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.

      You may find more information in syslog or the output from dmesg

Somehow, Windows is to blame, for this *only* happens after a 'warm reboot'
from Windows. After a power-on boot or a reboot from Linux there is only one
line in the logs about ymfpci, effectively saying that the module has been
loaded and is ready for its job.



B.F.M. Kal
Anjelierstraat 1,   2014 TC Haarlem,  Netherlands
tel +31 23 5324909, benkal@euronet.nl

Reply to: