[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: sound: loading of sound driver fails after reboot from Windows

On 2 Jun 2003 "Gary L. Dolan" <fred1@inebraska.com> wrote:

>On Mon, Jun 02, 2003 at 12:28:45AM +0100, Ben Kal wrote:
>> Hi folks,
>> Do some of you know more about the following inconvenience I have
>> with sound on my Linux machine:
>>   sound works fine if I boot directly into Linux after power-on,
>>                and if I reboot from Linux back into Linux;
>>   sound does not work at all after rebooting into Linux from Windows.
>> In Windows sound works under all circumstances.

> I remember having this problem, unfortunately I cannot remember how I 
> corrected it. I used to boot linux with Loadlin. When I got this box
> (which is now a number of years old), this same problem began. It appeared
> that Windows had a problem releasing the IRQ, so the only solution was a
> hard reboot. I <think> the problem was cleared up when I switched to grub
> as a boot manager.

Thanks, you were the only one who had something useful to say on this.
As no further reactions are forthcoming I consider this little thread closed
with the following conclusions:
- Windows (Windows 2000 at least, that's the variant on my laptop) somehow
  keeps a grip on the sound card even after it has been stopped, possibly by
  "not releasing the IRQ";
- switching to grub as boot manager may solve the problem;
- otherwise there is nothing but a hard reboot if yow want sound in Linux.

Thanks again,


B.F.M. Kal
Anjelierstraat 1,   2014 TC Haarlem,  Netherlands
tel +31 23 5324909, benkal@euronet.nl

Reply to: