[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: sndconfig problems: sound only works until reboot

--- Donald Spoon <dspoon@astcomm.net> wrote:
> Joris Huizer wrote:
> > Hello everybody,
> > 
> > I don't know wether this is important so to be
> sure I
> > send this.
> > In an old email I found somebody suggesting lspci;
> > Here is the output:
> > 
> > 00:00.0 Host bridge: OPTi Inc. 82C701 [FireStar
> Plus]
> > (rev 32)
> > 00:01.0 ISA bridge: OPTi Inc. 82C700 (rev 31)
> > 00:0a.0 CardBus bridge: Texas Instruments PCI1131
> (rev
> > 01)
> > 00:0a.1 CardBus bridge: Texas Instruments PCI1131
> (rev
> > 01)
> > 00:12.0 VGA compatible controller: Neomagic
> > Corporation NM2160 [MagicGraph 128XD] (rev 01)
> > 00:13.0 USB Controller: OPTi Inc. 82C861 (rev 10)
> > 00:14.0 IDE interface: OPTi Inc. 82C825
> [Firebridge 2]
> > (rev 30)
> > 
> > Now, I thind this output a bit confusing: Not a
> word
> > about ESS 1869, so does this mean this laptop
> doesn't
> > have that card?? I saw at a few pages this card is
> > normally used on Compaq Pressario 1245 - but why
> isn't
> > it showing up?? Or is it named differently
> somehow?
> > 
> > Can this output help anyone help me what the
> sndconfig
> > does to make sound work - temporarily :-( ?
> It tells me that the sound chip ISN'T hooked
> directly to the PCI bus.
> It is probably sitting off the ISA bus, and probably
> ISN'T Plug & Play.
> More helpful to me is your origianl post saying you
> got it working with
> the SoundBlaster drivers via Sndconfig, but the
> settings disappear when
> you re-boot.  I suspect what is happening is the
> proper modules &
> settings are being inserted into memory via
> modprobe, but the file
> changes needed to re-load these modules on the next
> re-boot are NOT
> being made.
> I have not used Sndconfig here recently, but as I
> recall it  first
> tested the system with the requested modules &
> settings, THEN wrote the
> proper changes to /etc/modutils/sndconfig file if
> they worked.  I am not
> sure what it did after that, but once this file is
> written, it "should"
> have run "update-modules" to re-write the
> /etc/modules.conf file with
> the new settings.  This is the file that is read at
> every bootup to
> insert the desired modules.  You shouldn't edit the
> /etc/modules.conf
> file directly, but let it be re-written by
> "update-modules".
> I suggest you take a look and see if the
> "/etc/modutils/sndconfig" file
> is present on your system.  It "should" be there as
> a result of your
> previous incantation of Sndconfig.  If it is there,
> just run the command
> "update-modules" as root, and try a re-boot.  That
> should make it work.
>   If it isn't there, you should re-run sndconfig and
> make sure you
> "save" the changes.  Check /etc/modutils/sndconfig
> to make sure it is
> there and jump into the above routine.

Well I see you are up to date on sndconfig allright
Indeed, sndconfig writes a /etc/modutils/sndconfig; It
*forgets* to run update-modules but that's just a
small problem.

I did more searches, including just the name sndconfig
- and I found a doc which discribes how sndconfig
works at
However, some things don't happen: it doesn't seem to
do anything with /etc/isapnp.conf, and the sample midi
isn't played either.

> Finally, it is possible that Sndconfig is not doing
> what it is supposed
> to do.  It could be "broken" (have you checked the
> buglists?) or
> something else is interfering with it.  I noticed in
> previous posts that
> you had experimented with ALSA.  ALSA will work, but
> I have found it to
> be a bit more difficult to setup.  IF you have any
> ALSA stuff still on
> your system, it could easily be interfering with the
> OSS sound setup
> used by sndconfig.  I would suggest sticking with
> one or the other.  IF
> you want to use sndconfig, remove all the ALSA
> packages.  IF sndconfig
> isn't writing the file mentioned above, you could
> always try inserting
> the needed modules with the "modconf" program. Once
> you know which ones
> are needed, then using modconf will insure they get
> inserted properly
> and will be re-loaded upon the next reboot.

I might have a look at possible buglists in a few;
Yeah at first I was told I should use ALSA but later
on I saw sndconfig being mentioned in a page on my
laptop so I thought let's give it a try; Later on I
did a new kernel compilation without ALSA so alsa
shouldn't be in the way. Anyway, I removed all
programs which had to do with ALSA after your post.

> BTW, this is just an "educated guess".  I don't have
> that particular
> sound chipset here...
> > 
> > BTW, I put a question on a forum but after one
> > response (and my answer) they got silent - is this
> an
> > unusual problem or something ?
> > 

Well actually this is not true anymore - it was just
silent for a few days.
You may have a look at
for the disscussion.
(Many of the facts I mentioned here are mentioned
there too)

> I went to the Debian-User Archives and searched on
> your name in order to
> review the original post on this subject.  I notice
> you have over 30
> posts to Debian-User on a variety of subjects...
> most with LOTS of
> answers!  I think you should be able to answer your
> question with a
> little thinking.  People DO help... when they think
> they have something
> to contribute... I suspect not too many people have
> run into your
> particular "problem" on this one.  Personally, I
> feel a bit
> uncomfortable "guessing" at a solution to your
> problem since I don't
> have your equipment here, but I thought I would add
> the above
> "generalities" for whatever they are worth.  If you
> think about it,
> lists like this one NEVER solved a "problem"... all
> they do is point
> you in the proper direction for YOU to solve it! 
> After all you are the
> one at the keyboard and with the hardware...
> Cheers,
> -Don Spoon-

Yeah you are right about that, I've been posting and
posting here on many subjects - and most of the time I
get helpfull responses - it's true a list can't really
*solve* the problem, but it can be very efficient to
get me on the right track :-)
Anyway, I must say, I get responses again at the
forum, I guess people were just busy for a few days.
With this list as reference that seems to be a long
time :-D

Today, I noticed the weirdest I ever saw on this: I
had moved the sndconfig to the /root dir (so it wasn't
loaded) and placed it again in /etc/modules.conf - and
then sound worked... that is, untill I logged off.
That temp. working thing was after a reboot, so I
think nothing of the sndconfig can be in memory

Could I somehow, eh, use this behavior, like, removing
the sndconfig stuff from memory and reloading it? The
problem is ofcourse it would have to be done on each
login (even when I log off of gnome. and log in again
- sound is gone !)

Is there a root script being run when somebody logs in
into gnome (like ~/.bashrc which is run with every new
bash shell)?



Do you Yahoo!?
Yahoo! Calendar - Free online calendar with sync to Outlook(TM).

Reply to: