[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Linux vs Windows

On Sun, 2003-05-18 at 11:07, David Z Maze wrote:
> Ron Johnson <ron.l.johnson@cox.net> writes:
> > Thus, you use XFree v4.x in svga mode, or v3.3.6 and the drivers for
> > your card, and that limits the amount of new GUI apps you can use w/o
> > backporting or recompiling.
> >
> > Even fvwm 2.2 in sarge is compiled against XFree 4.1, so it would
> > have to be recompiled for XFree 3.3.6.
> This isn't at all the case.  Just because you're using an X server
> from XFree86 3.3.6, you can still use local X clients compiled against
> any version of the X libraries.  There's no particular requirement
> that you even use XFree86 or even Xlib, just so long as you have
> something speaking the right (extremely stable; X11R6 is around a
> decade old now) wire protocol.

Thanks for the info.

Still, if you do "apt-cache show fvwm", you'll see that it depends
on "xlibs (>> 4.1.0)".  Maybe my understanding of Debian is all wrong,
but that tells me that if fvwm & XFree are on the same box, and you're
using apt-get/dpkg to manage the software, it will balk if you try
to install pre-compiled fvwm against pre-compiled XFree 3.3.6

| Ron Johnson, Jr.        mailto:ron.l.johnson@cox.net          |
| Jefferson, LA  USA      http://members.cox.net/ron.l.johnson  |
|                                                               |
| The purpose of the military isn't to pay your college tuition |
| or give you a little extra income; it's to "kill people and   |
| break things".  Surprisingly, not everyone understands that.  |

Reply to: