[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: webmin problem

When I dpkg -P webmin, I get:
 dpkg -P webmin
dpkg: dependency problems prevent removal of webmin:
 webmin-raid depends on webmin.
 webmin-core depends on webmin.
dpkg: error processing webmin (--purge):
 dependency problems - not removing
Errors were encountered while processing:

When I dpkg -P webmin-raid it says it depends on webmin-core ad then
fails. When I dpkg webmin-core is says it depends on webmin-raid and
then fails.

I wish I understood this better. It is frustrating to have something
installed that doesn't work and then even more frustrating to be unable
to uninstall it.

I any other ideas would be very much appreciated.


On Sat, 2003-05-03 at 02:51, Stephen Birch wrote:
> Hash: SHA1
> After making copies of any configuration files you may have edited, 
> use dpkg to completely remove webmin:
> dpkg -P webmin
> Then use "apt-get install webmin" to do a fresh install.
> Steve
> On Wednesday 30 April 2003 23:50, Mike Kordik wrote:
> > Now I really did it! I tried uninstalling webmin and then
> > installing again to see if that would do it. I did this before I
> > read this message. BTW I do not have X running so I would have to
> > use Lynx. I really wished I had tried that first.
> >
> > Anyway, I did apt-get remove and then apt-get install. It didn't
> > fix the problem. I noticed after a remove there are still webmin
> > files hanging around so I deleted them by hand. Now it won't even
> > install correctly. It doesn't install /etc/init.d/webmin. I tried
> > isntalling the webmin-core stuff as well (don't know why but I was
> > desperate) it gave me a RAID error. My first Linux computer is
> > running Gentoo and I got used to webmin I really wanted to run it
> > on Debian but I think I really messed things up. Is it hopeless?
> > Should I give up on webmin?
> >
> Version: GnuPG v1.2.1 (GNU/Linux)
> 0DJr5oYkFB5YVt/Lai21zbwhZW+QLCBhEsUeAj71KU+5OV9BK3vITajaQPfRaIFE
> 7Od3nLx3V8Mq2Wtem6/ENnSbh6O8ONMCCTYjQX6XlXnk4XJgJNUgiwX0Qq6653GP
> /sJpGikgvGo=
> =pOB0

Reply to: