[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: libXFt and konqueror

John Habermann wrote:
Apt doesn't seem to have any problems with my kde packages, but all the kde apps that I try and run fail with exactly the same error. For example kedit gives exactly the same error as konqueror

"kedit: relocation error: /usr/X11R6/lib/libXft.so.2: undefined symbol: FcInit"

I tried running ldconfig -X but I am still getting the same error. kdeinit fails as well so it appears that all kde based apps have got this problem. Could it be a problem with Qt or someother kde dependency. I am afraid I don't have idea of what is involved.

in /usr/X11R6/lib libXft.so.2 is just a sym link to libXft.so.2.0. Is that right?

I ran  ldd /usr/X11R6/lib/libXft.so.2 and got the following output

"        libXrender.so.1 => /usr/X11R6/lib/libXrender.so.1 (0x6ffa6000)
       libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x6ff26000)
       libz.so.1 => /lib/libz.so.1 (0x6fef6000)
       libc.so.6 => /lib/libc.so.6 (0x6fd9d000)
       libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x6fd6b000)
       libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x6fc70000)
       /lib/ld.so.1 => /lib/ld.so.1 (0x08000000)
       libdl.so.2 => /lib/libdl.so.2 (0x6fc4d000)

I have kde 3.1.0 that I compiled using the garnome based kde app and that runs fine. I don't have these apps in my path, just start them with ./

Thanks for you help


It looks like others are having this problem too. You might want to take a look at the following bug report:

Debian Bug report logs - #186042
libxft2: relocation error: /usr/X11R6/lib/libXft.so.2: undefined symbol: FcInit

at: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=186042.

If you drill down and look at the message on 31 Mar 2003 from Michael Shields, you will see that he has a "work-around". I don't understand it, but maybe you will.

It looks like an open bug from what I see. Dunno why your machine is affected and mine is not. I am using KDE 3.1.1 binaries from "unstable" and the same libXft2 as you and it all works fine here. I also am using XF86 version 4.2.1 for whatever that might be worth..

Maybe the following info would also be helpful. Here is what I get on my machine from your ldd command:

ldd /usr/X11R6/lib/libXft.so.2
        libXrender.so.1 => /usr/X11R6/lib/libXrender.so.1 (0x4001b000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x40021000)
        libz.so.1 => /lib/libz.so.1 (0x40071000)
        libc.so.6 => /lib/libc.so.6 (0x4007e000)
        libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x4018e000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x4019b000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)
        libdl.so.2 => /lib/libdl.so.2 (0x40255000)

Note the differences in the next-to-last line. The "ld-linux.so.2" is from the newer glibc (libc6 2.3.1-16). Do you have it installed? I know some were holding off on installing it because of some problems earlier. Those "problems" seem to be "fixed" now.

Cheers & Good Luck!
-Don Spoon-

Reply to: