[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Kernel suddenly wants devfs and gives kernel panic

On Saturday 26 April 2003 11:19, David Goodenough wrote:
> I have a machine which has been happily running a customer kernel 2.4.20
> for a while now.  Yesterday I needed to add in support for a USB mouse and
> a USB floppy drive (the machine has no floppy built in) and first I
> installed hotplug so that it would auto-configure the floppy drive - which
> it did.
> Then I use make xconfig to load the old config file, change it to include
> the USB HID support, save it as a new config, rebuild the kernel using
> make-kpkg and dpkg -i the resulting deb.  Then the fun started.
> When I rebooted the kernel gets to the place where it loads the RAMDISK
> (being a 2.4 kernel I have --initrd support, and have had for a while)
> and then the next thing it reports is that has freed up unused kernel
> memory, that it can not open /etc/mtab, and then it complains that modprobe
> can not load devfs.  After a few more messages along the same lines the
> kernel stops with a panic.
> Now I have looked at /etc/fstab, and there is absolutely NO reference to
> devfs at all, not even in a comment and not even in a file whose name
> starts /etc/fstab (there are none).
> I have double checked the config, and the only change is the one about
> USB HID support, the DEVFS options are all turned off.  diff tells me that
> the only difference is to the line defining CONFIG_USB_HIDINPUT which is
> now set to y.
> I realised that although I had installed hotplug I had not installed
> usbutils, so I tried that, but is makes no difference.
> The alternate kernel I have installed (2.2.20-idepci) starts without
> problems.
> Anyone got any ideas why this might be happening?
> Regards
> David

Well I tried reinstalling the old 2.4.20 kernel, same symptom.  So I tried
removing hotplug, same symptom.

Then I looked in the initrd.img-2.4.20 that was created by postinst when
I installed the kernel, and it is stuffed full of references to devfs.  There
is a /devfs directory, and most of the devices in /dev are links to /devfs
entries.  So why is postinst generating all these references when devfs is
not configured.

I am by the way using unstable.  Now initrd-tools has changed recently, 
does it use devfs by default now?



Reply to: