[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ADSL connection doesn't work

this not much a good help, but it append to me too. I solved it by checking out cables. I spend about two hour of madness on it and all I needed was plug it properly in. ;-)Well, I know that it probably not your problem, but you can try it out.
Cheers Petr

Vincent Lefevre wrote:

I've tried to connect a PC (Debian testing) via ADSL, but I can't
make the connection work.

First, I've tried pppoeconf, but it says:

x Sorry, I scanned 1 interface(s), but the Access x x Concentrator of your provider did not respond. Please x x check your network and modem cables. Another reason for x x the scan failure may also be another running pppoe x x process which controls the modem. x
I've also tried by configuring the /etc/ppp/peers/dsl-provider file
(setting the 'user' option, trying 'pty "/usr/sbin/pppoe ... -m 1412"',
and demand-dialing) and executing the /etc/ppp/ppp_on_boot.dsl script,
but this doesn't work. A 'ifconfig -a' shows eth0, lo and ppp0, and
more precisely for ppp0:

ppp0    Link encap:Point-to-Point Protocol
       inet addr:  P-t-P:  Mask:
       RX [...] (all 0)
       TX [...] (all 0)
       collisions:0 txqueuelen:3
       RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

The 'LAN', 'Line TX', 'Line RX' of the ADSL modem (Alcatel Speed Touch
Home) are always off. The Ethernet card is a nVidia on a K7N2 (MS-6570)
motherboard and I use the driver from


Note: When the PC is connected to the modem via a router (so, not
using PPPoE on the PC side), there are no problems. This eliminates
many possible problems (cables, modem...).

Any idea?


Reply to: