[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.4.20 kernel and RTL8139

What happens if you try manually (as root) to assign an IP address using

/sbin/dhclient eth0

When you compiled the new kernel, did you include the PACKET and FILTER
options under networking? THese are required for dhcp client.

Hope this helps.

Andrew J Perrin - http://www.unc.edu/~aperrin
Assistant Professor of Sociology, U of North Carolina, Chapel Hill
clists@perrin.socsci.unc.edu * andrew_perrin (at) unc.edu

On Tue, 15 Apr 2003, Alexander Borghgraef wrote:

>  I'm having a problem getting my on-board NIC to work with the 2.4.20
> kernel. I was using Debian with the old 2.2 kernel, under which the
> network card worked fine. Then I upgraded to the 2.4.20 kernel, and
> suddenly I'm unable to connect to the dhcp server. Using lilo to boot
> the old kernel still works fine.
>  Before you ask, yes I did include the 8139 card in menuconfig. When
> I run ifconfig, eth0 appears in the list alongside lo (loopback device),
> but it doesn't get an IP address like it did in 2.2. Pinging the network
> card ( works, but that's lo I guess? Has anyone had similar
> problems, and if so, how do you solve them?
> --
> Alex Borghgraef
> --
> To UNSUBSCRIBE, email to debian-user-request@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: