[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Compiling a KDE app (configure: error: Qt ...)

I didn't think this would be asking so much....

I'm trying to compile a wireless networking monitor tool for KDE3. Either kwavecontrol, kwifimanager, or kwirelessmanager will do. The problem is that the install process for all of them starts with running "./configure".

When I run "configure", it always aborts with:
checking for Qt... configure: error: Qt (>= Qt 3.0.2) (library qt-mt) not found. Please check you installation!

Now, I must have tried just about every package with "qt" and "-dev" in the title. I've also tried the "--prefix=/usr --with-qt-includes=/usr/include/qt3 --with-qt-libraries=/usr/share/qt3/lib" options and that doesn't seem to help either.

I've seen other messages that say that it possible that using a different version of gcc than the one used to compile Qt can cause this, too... but I have no idea how to check which version of gcc compiled my Qt... and I'm not inclined to try every combination of gcc with every combination of Qt libraries.

This *can't* be all that unusual of a thing to want to do. Someone *must* be having success with it.

Can someone out there tell me, in simple terms:
1 - Which qt libraries (and other packages) I need....
2 - Which gcc I need..., and
3 - Which command line options I need...
in order to successfully run the "configure" scripts that come with these three KDE apps.

Incidentally, this is a system that is up-to-date with the "unstable" package set.

- Joe

Reply to: