[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: How to get PHP4 to work with Apache2



On Wed, Mar 05, 2003 at 01:06:41AM -0600, John Foster wrote:
> I need any suggestions on how to get Php4 to install and work with 
> Apache2; running mostly unstable with a lot of AMD  optomized w/gcc3.2 
> apps. PHP4 from Debian will not install without installing apache-common 
> (1.3) I think.

Yup.  PHP (4.2, at the VERY least) doesn't work with apache2 yet.  Well,
I think PHP does, but making all the libraries it links to threadsafe is
a bloody huge job.  It'd probably work quite safely with apache2's
fork()-based MPM model, but if you're going to use that, you might as
well use apache1.3.

May I ask why you want apache2 so badly?

-- 
Rob Weir <rweir@ertius.org>				http://ertius.org/

Attachment: pgpUl0ntiJKup.pgp
Description: PGP signature


Reply to: