[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems with X and unstable

Chris Hoover wrote:
On Sun, Mar 02, 2003 at 12:46:16PM -0500 or thereabouts, andyrew wrote:

Chris Hoover wrote:

(EE) Failed to load module "pex5" (module does not exist, 0)
Skipping "/usr/X11R6/lib/modules/fonts/libspeedo.a:spencode.o": No symbols found
(EE) Failed to load module "xie" (module does not exist, 0)
Symbol FontFilePriorityRegisterRenderer from module /usr/X11R6/lib/modules/fonts/libxtt.a is unresolved!
(II) [GLX]: Initializing GLX extension

	This should not happen!
	An unresolved function was called!

Fatal server error:

If you're managing your /etc/X11/XF86Config-4 with debconf, try:

[root@host:]# dpkg-reconfigure xserver-xfree

Dang--the above should have read xserver-xfree86 . . . are you _not_ managing XF86Config-4 with debconf?

and make sure that

[ ] pex5
[ ] xie
[ ] glx

extensions don't have 'x' in their boxes (you _might_ want to do the same for speedo, too, while you're at it). Do a

[user@host:~]$ startx

to see if that helped.

If your editing /etc/X11/XF86Config-4 yourself, just comment-out those lines (add a '#' to the beginning of the line), and

[user@host:]~$ startx

Check-out /usr/share/doc/xfree86-common ;-)

Thanks, that fix worked.  However, is this not a bug with the latest unstable
packaging?  I mean, my X config was working perfect, X packages updated and
then my X is broken??? If this is a bug as I think, how do I properly report

I didn't have any problems with the 4.2.1-6 upgrade, but that doesn't mean that it should have worked for you--everyones' got a different configuration.

http://www.debian.org/Bugs/Reporting would be the place to start for bug reporting.

I'm a little confused about the matter, too--if you were managing XF86Config with debconf, it should take you through the steps when a new revision gets uploaded. It will also overwrite any changes you have made between the ####### and the #######--if there are any additions you need to make to XF86Config-4, add them either before, or after, the #######.

If you are editing it yourself, I don't think it should have overwritten the Config (unless there is also something awry with your debconf configuration (check with 'dpkg-reconfigure debconf'). I let debconf manage everything, and I have it always ask me the same old questions every time it does something just to be careful.

Have fun breaking something else ;-)

Reply to: