[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Usb mouse and X server

Hi i have a logitech optical cordless mouse with 2 buttons on top and one on the side.

I'm trying to make it work on the USB port so i can startx my X server

I enabled "Input Core Support", "Mouse Support" and "hid"
The gpm server starts nicely but the X server doesn't :

(**) Option "XkbLayout" "fr"
(**) XKB: layout: "fr"
(==) Keyboard: CustomKeycode disabled
(**) |-->Input Device "Configured Mouse"
(WW) The directory "/usr/lib/X11/fonts/cyrillic" does not exist.
Entry deleted from font path.
(**) FontPath set to "unix/:7100,/usr/lib/X11/fonts/misc,/usr/lib/X11/fonts/100
(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(--) using VT number 7

(WW) Cannot open APM
(II) Module ABI versions:
XFree86 ANSI C Emulation: 0.1
XFree86 Video Driver: 0.4
XFree86 XInput driver : 0.2
XFree86 Server Extension : 0.1
XFree86 Font Renderer : 0.2
(II) Loader running on linux


(**) MGA(0): Depth 24, (--) framebuffer bpp 32
(==) MGA(0): RGB weight 888
(II) Loading sub module "mga_hal"
(II) LoadModule: "mga_hal"
(II) Loading /usr/X11R6/lib/modules/drivers/mga_hal_drv.o
(II) Module mga_hal: vendor="The XFree86 Project"
compiled for 4.0.3, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.3
(II) MGA(0): Matrox HAL module used
(--) MGA(0): Chipset: "mgag400"
(==) MGA(0): Using AGP 1x mode
(--) MGA(0): Linear framebuffer at 0xE4000000
(--) MGA(0): MMIO registers at 0xEFEFC000
(--) MGA(0): Pseudo-DMA transfer window at 0xEF000000
(--) MGA(0): BIOS at 0xEFEE0000
(--) MGA(0): Video BIOS info block at offset 0x07A80
(WW) MGA(0): Video BIOS info block not detected!
(II) MGA(0): MGABios.RamdacType = 0x0
(**) MGA(0): VideoRAM: 32000 kByte
(II) Loading sub module "ddc"


(II) Loading sub module "i2c"
(II) LoadModule: "i2c"
(II) Loading /usr/X11R6/lib/modules/libi2c.a
(II) Module i2c: vendor="The XFree86 Project"
compiled for, module version = 1.2.0
ABI class: XFree86 Vid eo Driver, version 0.4
(WW) System lacks support for changing MTRRs
(II) MGA(0): I2C bus "DDC" initialized.
(II) MGA(0): I2C device "DDC:ddc2" registered.
(II) MGA(0): I2C device "DDC:ddc2" removed.
(II) MGA(0): I2C Monitor info: (nil)
(II) MGA(0): end of I2C Monitor info


and it finishes like that

(II) Initializing built-in extension RENDER
PEXExtensionInit: Couldn't open default PEX font file Roman_M
(II) Keyboard "Generic Keyboard" handled by legacy driver
(**) Option "Protocol" "ImPS/2"
(**) Configured Mouse: Protocol: "ImPS/2"
(**) Option "CorePointer"
(**) Configured Mouse: Core Pointer
(**) Option "Device" "/dev/input/mice"
(==) Configured Mouse: Buttons: 3
(**) Option "ZAxisMapping" "4 5"
(**) Configured Mouse: ZAxisMapping: buttons 4 and 5
(II) XINPUT: Adding extended input device "Configured Mouse" (type: MOUSE)
Could not init font path element unix/:7100, removing from list!
(II) MGA( 0): [drm] removed 1 reserved context for kernel
(II) MGA(0): [drm] unmapping 4096 bytes of SAREA 0xd8848000 at 0x40014000

There is a few warnings which i don't know the reason.
But there aren't any obvious reasons why X won't start, does anybody have an idea ???


Do You Yahoo!? -- Une adresse @yahoo.fr gratuite et en français !
Testez le nouveau Yahoo! Mail
Reply to: