[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Newbie bull brings own china shop.

Knoppix got finished earlier than expected. I first tried it on another machine on my WAN/LAN to see if the CD would work with another configuration. This went off without a hitch, though it is necessary to prompt Knoppix to search for a dhcp assignment of an IP address by using "netcartconfig". I gave the command "knoppix noapic" at the boot prompt on my daughter's computer, and then used the "netcartconfig" tool to get an IP address assigned by DHCP. Unfortunately, this didn't work.

I added the lines that you suggested to /etc/interfaces (there were no contents to start with in the file). I then rebooted. There was no output to the command "# /sbin/ifconfig" or "ifconfig". However, a new line prompt did appear.



sean finney wrote:

On Sat, Mar 01, 2003 at 03:10:14PM +0700, Brian Durant wrote:
OK Sean, the output of "# /sbin/ifconfig eth0" was "eth0 Media Link Off". The result of "$ ping" was "Network is unreachable" :-(

i've never seen that error out of ifconfig before, and can't even find
it in the source code for the program.   okay, while you're waiting for
the knoppix cd, how about you try this:

- in /etc/interfaces, take out all lines mentioning eth0, then put
 the following in:

auto eth0
iface eth0 inet static

and then just reboot the whole machine, and see if you get an address
out of ifconfig when you get back to a prompt.

also, i just have to ask--have you tried this with another cable, and
have you tried this in one of the ports on the hub that you know to work?


Reply to: