[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

debconf and dpkg-reconfigure behavior


I have just encountered a problem that I have never seen during the
installation of many, many Debian machines.  I am mysitified and perhaps
someone has a suggestion (probably some thing stupid, of course).

I have been asked to help out with a newly installed machine (Woody) and
when I added packages, I noticed that there were no debconf screens or
questions for any packages.

The command

# dpkg-recnfigure debconf

Just returns to the prompt with no other output.  From the debconf manual,
this should at least ask me the quetions using the Dialog method.

I have tried installing all the packages that exist on a working
installation and this has no effect.  I have tried manually editing the
/var/cache/debconf/config.dat file to set options the way I want them for
debconf but when I rerun the command above, debconf wipes out all the text
I had placed in the file for debconf.  The entries now look like:

Name: debconf/frontend
Template: debconf/frontend
Owners: debconf
Flags: seen

Name: debconf/priority
Template: debconf/priority
Owners: debconf
Flags: seen

This is quite mystifying and I really do not know how to get out of this
funny state.  I have tried to uninstall debconf (using --force-depends)
and then reinstalling it to no avail.



Carlo U. Segre -- Professor of Physics
Associate Dean for Research, Armour College
Illinois Institute of Technology
Voice: 312.567.3498            Fax: 312.567.3494
Carlo.Segre@iit.edu    http://www.iit.edu/~segre

Reply to: