[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Stumped: openAFS client "Connection Timed Out"

I have a home network that includes a linux machine using iptables to NAT
packets from three user machines: a laptop (debian 3.0, 2.4.18 kernel), a
desktop (debian 3.0, 2.4.20 kernel) and a windows machine. The two debian
machines run openAFS clients to connect to UNC's AFS servers.

This setup has worked fine for quite some time now. Sometime in the past
two weeks, though, it's stopped working for the debian desktop, but it
still works fine for the debian laptop.  I'm fresh out of ideas, and would
appreciate some pointers.

The symptom is simple:
aperrin@joehill:~$ ls -lad afshome
lrwxrwxrwx    1 aperrin  aperrin        34 Oct 17 14:11 afshome ->
aperrin@joehill:~$ cd afshome
bash: cd: afshome: Connection timed out

Same happens if I go directly *to that directory*:
aperrin@joehill:~$ cd /afs/@cell/home/a/p/aperrin
bash: cd: /afs/@cell/home/a/p/aperrin: Connection timed out

But not if I go to the parent directory:
aperrin@joehill:~$ cd /afs/@cell/home/a/p        

Notice that it's not just my home directory:
aperrin@joehill:/afs/@cell/home/a/p$ ls
ls: apackouz: Connection timed out
ls: apendyal: Connection timed out
ls: apickett: Connection timed out
ls: apperson: Connection timed out
ls: aphenry: Connection timed out
ls: apedrett: Connection timed out
ls: apyles: Connection timed out
ls: apowens: Connection timed out
ls: aprovost: Connection timed out
ls: apjordan: Connection timed out
ls: apalmer1: Connection timed out
ls: apharris: Connection timed out
ls: apoe: Connection timed out
ls: aprilnee: Connection timed out
ls: aplonk: Connection timed out
ls: appi: Connection timed out
ls: apatel23: Connection timed out
ls: apescato: Connection timed out
ls: apca: Connection timed out
ls: apghosh: Connection timed out
apacker   apathak   apeay    apersson  apickard  apollard  aprange
apadams   apaules   apeele   apeters   apierce   apolychr  apresler
apadro    apaulsen  apeery   apeterso  apinnix   aponte    apresley  aps
apai      apayne    apei     apettifo  apiran    aponton   apribisk
apalmer   apb       apence   apfields  apirzade  apostros  aprice    apugh
apalwai   apbowers  apenney  apgar     apittman  apottle   apriest
apares    apcook    aperez   aphaber   apjones   apowers   apriljoy
aparikh   apcurtis  aperou   aphalej   apkarian  apparao   aprillew
aparrish  apeacock  aperrin  aphayes   apkumar   appatel   aprilr
apartin   apease    aperry   aphelps1  apleland  appel     aprince
apassann  apeat     apersky  aphillip  apmorgan  applegat  apropos

And that it works fine from the laptop:
aperrin@simmel:~$ cd /afs/@cell/home/a/p/aperrin

I've tried restarting both the NAT masq'er and the client machine, as well
as using fs flush, with no luck.  Any further advice?

Both machines are unning openafs-modules-source 1.2.5-1.

joehill:~# uname -a
Linux joehill 2.4.20 #1 Sat Feb 15 14:51:12 EST 2003 i686 unknown
joehill:~# modinfo openafs
filename:    /lib/modules/2.4.20/fs/openafs.o
description: <none>
author:      <none>
license:     <none>

simmel:~# uname -a
Linux simmel 2.4.18 #1 Thu Jan 9 10:50:33 EST 2003 i686 unknown
simmel:~# modinfo openafs
filename:    /lib/modules/2.4.18/fs/openafs.o
description: <none>
author:      <none>
license:     <none>

Andrew J Perrin - http://www.unc.edu/~aperrin
Assistant Professor of Sociology, U of North Carolina, Chapel Hill
clists@perrin.socsci.unc.edu * andrew_perrin (at) unc.edu

Reply to: