[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Help Please :: Kernel Upgrade Problems with Booting from Raid HPT370

Hi All

    I run an ABIT KT7A-Raid Mainboard with two Segate 40gig disks connected
and striped with raid0. I have recently installed debian from the 3.0 ISO
using the 2.4.18-bf24.4 Kernel.

    The system works fine, but of course I am not satisfied with the kernel,
and I wish to configure and upgrade the kernel to 2.4.20 or (failing that)

    I have recently tried to build the new kernel(s) and configured them,
and staticly enabled the the hpt370 support option. However when I boot the
system in to the new kernel I get the error message below:

NET4 Unix domain sockets 1.0/SMP for linux NET4.0.
kmod: failed to exec /sbin/modprobe -s -k block-major-114, errno = 2
VFSS: Cannot open root device "7206" or 72:06
Please append a correct "root= boot option
Kernel panic: VFS: Unable to mount root fs on 72:06

Because the bf24 kernel was there origniall I am presuming that most of the
options in lilo.conf and in other places are correct for the new kernel

    e.g. root=/dev/ataraid/d0p6

So what is it that I am missing?

Thanks for your help

Reply to: