[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't upgrade from slink to woody!

On Sun, 2003-01-19 at 12:05, Pigeon wrote:
> Hi,
> Just got a set of Woody CDs (thanks Gerald!) to upgrade my slink
> system. I've copied them all onto hard drives as iso images and
> loopback mounted them (read only) to avoid mucking around swapping CDs.
> I then  used apt-cdrom to add them all to /etc/apt/sources.list, and
> ran apt-get update. It gets 64% of the way through Reading Package
> Lists and then segfaults.
> This is of course the slink version of apt, 0.3.11.
> The CD-ROM entries in sources.list are the only ones there.
> As a wild guess I tried the cache-limit cure for "dynamic mmap ran out
> of room" on the theory that maybe an older version of apt didn't give
> such a useful error message. It made no difference; varying the limit
> didn't affect the 64%.
> I have also tried dselect, but its multi-cd access method doesn't seem
> to work; it only lets me tell it about one CD at a time.
> Any ideas on how to get either of these methods working? Since the C
> libraries will be upgraded I have no desire to upgrade by hand!

Could you try updating to Potato first?  That way, you won't be
making such a huge version leap in almost every bit of software
in one step.

| Ron Johnson, Jr.     mailto:ron.l.johnson@cox.net          |
| Jefferson, LA  USA   http://members.cox.net/ron.l.johnson  |
|                                                            |
| "Basically, I got on the plane with a bomb. Basically, I   |
|  tried to ignite it. Basically, yeah, I intended to damage |
|  the plane."                                               |
|    RICHARD REID, who tried to blow up American Airlines    |
|                  Flight 63                                 |

Reply to: