[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Alan Cox patches [probably stupid question]



I want/need to compile one of the Alan Cox variants of the 2.4.20
kernel (it apparently has better support for the particular Asus
motherboard that I have). I've routinely hand-compiled kernels for
some years, but I've never tried any of the non-standard kernel
branches before.

I downloaded the 2.4.20 source from ftp.debian.org, uncompressed it,
un-tarred it. Then I downloaded patch-2.4.20-pre10-ac2 from the same
site, and tried:

  patch -p1 < patch-2.4.20-pre10-ac2

at the top of the /usr/src/linux-2.4.20/ tree.

It gets a certain distance and then:

patching file arch/alpha/kernel/process.c
patching file arch/alpha/kernel/smp.c
patching file arch/alpha/mm/fault.c
patching file arch/arm/config.in
patching file arch/arm/mm/fault-common.c
patching file arch/cris/drivers/ide.c
patching file arch/i386/config.in
patching file arch/i386/defconfig
patching file arch/i386/kernel/apic.c
Reversed (or previously applied) patch detected!  Assume -R? [n] n
Apply anyway? [n] y
Hunk #1 FAILED at 29.
Hunk #2 succeeded at 262 (offset 1 line).
Hunk #3 FAILED at 304.
2 out of 5 hunks FAILED -- saving rejects to file arch/i386/kernel/apic.c.rej
patching file arch/i386/kernel/apm.c
patching file arch/i386/kernel/dmi_scan.c
Reversed (or previously applied) patch detected!  Assume -R? [n] 

At that point, no matter what options I select, I end up with `Hunk
FAILED' messages. The process repeats.

I'm sure I'm making some really basic mistake here. Could someone
kindly point me in a useful direction? Thanks,

Jim



Reply to: