[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

new install with idepci && NIC problems


Bought a Dell Dimension 4550, wiped MS from the harddisk and installed Debian. Well, I tried. Somehow I've installed the idepci flavor. (Why is this the default?) Anyhow, I can't get the NIC to work. The Dell documentation says it's an Integrated Intel 10/100 Pro network adapter. I tried to load the eepro100 module, and some of the others that came installed but I get barked at. I downloaded a driver from Intel that I think is the correct one (sorry can't give any more details for now, pc's at home, I'm at work), tried to compile it, but make says it cant't find the kernel sources. I had my first go at apt-get to install the source code of the kernel for 2.2.20. Unpacked this and told the makefile for the driver where to find the kernel source. Now it's complaining that the version of the installed kernel is not identical to the version of the kernel source. And indeed, when I say 'uname -a' it tells me that the version is something like 2.2.20-idepci. Compiling fails miserably. Now what do I do? Should I recompile the kernel? Perhaps go for version 2.4 right away? Will this fix my network problem? Or should I do a complete re-install with the vanilla flavor?

Thanks for the help.

Koen Dejonghe.

MSN 8: advanced junk mail protection and 3 months FREE*. http://join.msn.com/?page=features/junkmail&xAPID=42&PS=47575&PI=7324&DI=7474&SU= http://www.hotmail.msn.com/cgi-bin/getmsg&HL=1216hotmailtaglines_advancedjmf_3mf

Reply to: