[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: rsync fails to copy (both 2.4.6-1 and 2.5.5-0.1) maybe other ways to copy?

> > It still fails at the pagefile.sys even though I tell it to exclude
> > pagefile and ntldr 2 different ways.  I have read the manpage but I am
> > very weak on proper syntax.  I tried with including the .sys extension as
> > well. No dice. Can you correct me here?  Is my PATTERN correct?
> > steelhead:~# rsync -av --ignore-errors --force --exclude "mnt/pagefile"
> > --exclude "mnt/ntldr" --exclude "pagefile" --exclude "ntldr" /mnt/ 
> > /root/nt
> I'd try changing "pagefile" to "pagefile.sys" or "pagefile*"

Still failing. How do I tell rsync NOT to copy the files in the root C:\ ?
(remember I used mount -t smbfs to mount the 2000Server C drive to /mnt)
I don't want to copy these files as rsync pukes on some of them: CONFIG.SYS 
NTDETECT.COM  boot.ini AUTOEXEC.BAT  MSDOS.SYS arcldr.exe ntldr
COMLOG.txt  IO.SYS  arcsetup.exe  pagefile.sys

I tried this command telling it to NOT copy those files using "/*.*" :
steelhead:~# rsync -av --ignore-errors --force --exclude "/*.*" /mnt/ /root/nt

But I get this error when it hits the ntldr file so it is trying to copy 
those files:

wrote 2014205144 bytes  read 317412 bytes  824104.13 bytes/sec
total size is 2014715194  speedup is 1.00
rsync error: partial transfer (code 23) at main.c(578)

Reply to: