[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: cups and hpijs driver

Michael Olds wrote:
Re: setting up DeskJet 960c as local printer on Woody box

I have reviewed the cupsomatic perl script situation and this basically
duplicates the work being done by the custom PPD and the foomatic-bin and
foomatic-db (at least that's how I understand it). I have also installed
cupsys-bsd, gv, and qtcups per various sets of instructions. So now I have
the following installed:

Still no joy.

I think the problem is occuring somewhere between the printer as hardware
which seems to be installed ok, and the various installed packages which
also seem to be set up ok. It's just that the two are not talking to each

Except for the fact that this may indicate something else wrong with my
setup, I'm about to say "Why do I need this?" since the printer off my W2K
box works fine and I could probably set up this printer on an open USB port
and have it up and running in two minutes (the little test it did for itself
looked like a very nice job of printing, better than the multi-function
OfficeJetT65 I use on the W2K box.)

1. What would be the best way to get everything print related out of the
machine to start over? Uninstall all of the above? Anything else?

2. Can I still be missing something in my kernel?

3. How do you command-line send a job to the printer? lpr and pdq both give
me: "command not found". I looked in modutls aliases and inserted the lines:
alias /dev/printers  lp
alias /dev/lp0       lp
alias parport_lowlevel parport_pc
and rebooted, but that did nothing, so I removed them. My thinking is it is
something like this that is the problem: no communication between the
parallel port and the printing drivers.

4. I tried printing from the Web, no go, but that's no real test as Mozilla
doesn't do anything for me except see pages (I just installed the browser).

5. The error message off Nedit has changed, and is now: lpr: unable to print
file: server-error-service-unavailable

Best Wishes!
Mike Olds www.buddhadust.org

Do a "lsmod" as root and see if the following modules are loaded:


They should be loaded IF you are using the parallel port on your computer. If you are using he USB, then you should have the appropriate USB drivers loaded, i.e.:


If any of these (depending on how you have the printer attached) are missing, add them to /etc/modules file and reboot. Re-check that they got loaded and re-configure your printer in CUPS.

I am using the parallel port here on my 960C and it detects it on bootup just fine. I havn't used the USB setup, so the above might be a bit off. I know for sure you need to add those 3 for USB...you might also need the "lp" module...dunno.

I see a message in the bootup messages indicating it "sees" the printer, and when I try the KDE Printing Manager it shows up already listed in the "Local Port Selection" screen of the Wizzard. You should also see the same thing, even if you are using the USB connection. If it isn't listed on the Wizzard, then your computer is not "seeing" it! You should also see it listed under the appropriate connection (parallel port or USB port) in the "device" screen on the CUPS web config tool.

-Don Spoon-

Reply to: