[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Kernel problems: QM_MODULES


I just recently started a new project; to put together a new
at home. Now, I installed Debian 3.0 on an old p2-machine and then I did an
dist-upgrade to
the latest unstable/testing.
Everything worked just fine, but then I decided to compile a new kernel and
that's when the
problems started. I downloaded the latest kernel (2.5.49) and started
configuring it according
to my personal needs, and I then did a make install as well as make modules,
and make modules_install.

Problem is, when I boot the computer with the new kernel I get the following
error messages
when it's starting to load the modules:

modprobe: Can't open dependencies file /lib/modules/2.5.49/modules.dep (No
such file or directory)

And when I try to run lsmod or depmod, I get:

lsmod: QM_MODULES: Function not implemented

After about an hour of searching the Internet for answers as to why this was
happening, I more
or less found out that this problem only comes up when you haven't enabled
module support in
your kernel. But I have enabled module support in my kernel..

I've also tried updating modutils from the latest unstable deb-package to
the latest source
found on ftp.kernel.org without any result.

Is there something that I'm missing? Did I forget to do something?
Any help is greatly appreciated.

Thanks in advance,
Tobias Bengtsson

Reply to: