[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: java from sun: installation problem

Jan Krupa <krupa@alpha.sggw.waw.pl> writes:

> I have debian3.0 (woody) installed).
> I run gnome.
> I tried to install j2se from
>  http://java.sun.com/j2se/1.4/download.htm
> downloaded the Linux self-extracting file:
>  j2sdk-1_4_0_01-linux-i586.bin
> I run
> javac HelloWorld.java 
> then
> appletviewer Hello.html 
> and got the following messages:
> Exception in thread "main" java.lang.UnsatisfiedLinkError: /usr/local/java/j2sdk1.4.1_01/jre/lib/i386/libfontmanager.so: libstdc++-libc6.1-1.so.2: cannot open shared object file: No such file or directory

Does this one gives you a clue? Your system can't find

What I did on my system was to create a symlink from whatever current
libstdc++-libc6 so library in /usr/lib is to
$HOME/lib/libstdc++-libc6.1-1.so.2 and add $HOME/lib to my LD_LIBRARY_PATH
env. variable.

Not really a solution in a Debian way(tm), but works.

HTH, Dragan

Dragan Cvetkovic, 

To be or not to be is true. G. Boole      No it isn't.  L. E. J. Brouwer

Reply to: