[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: newbie: cpio not working



On Mon, Dec 09, 2002 at 10:34:03AM -0800, alan brown wrote:
> I have the newest version of cpio (as confirmed by apt-get).
> 
> I'm trying to install oracle.  I've downloaded the 3 huge files
> (xxx.cpio.gz).  I copied them onto CD under windows XP and then copied
> them onto my linux box (because Oracle's website wouldn't work with
> Konquerer or Mozilla!).  I ran gunzip on them successfully (which
> implied to me that the files were not corrupted) and then tried to run
> 
> cpio -idmv  <filename>
> 
> On each of the unzipped files.  However, the command simply hangs.  I've
> left it alone for 15 minutes (as these files are hundreds of megabytes
> in size) but it just remains hung.  I then ran vmstat to see if the cpu
> was busy doing something but it was saying the cpu was completely idle.
> 
> Am I right in assuming that the files are not corrupted because I could
> unzip them?  Shouldn't cpio be telling me things that it's doing as it
> does them (as I set the 'verbose' flag)?
> 
> I looked at the man page for cpio and I seem to be doing the right
> things.  

I think cpio tries to read/write to/from standard input/output, so you
need to do something like

cpio -idmv * < archivename

or possibly

cpio -idmv -I archivename *

Also if the files are stored in the archive with absolute pathnames
(like /usr/bin/foo) cpio will try to extract the file foo to /usr/bin.
This will (a) fail if you're not root and (b) if you are root you're a
very trusting root (IMO). I'd therefore recommend

cpio -idmv --no-absolute-filenames * < archivename

to extract into a directory tree under the current directory.

I think your version is trying to extract the file filename from an
archive which it is waiting for you to type in at the keyboard!!!

Don't give up! cpio is a dinosaur and therefore has a tendency to act
weird at you. It always buggers me about on the rare occasions I use
it, but it does work eventually.

Pigeon



Reply to: