[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Help configuring old mozilla compile

* Pigeon (jah.pigeon@ukonline.co.uk) [021206 13:35]:
> On Thu, Dec 05, 2002 at 10:12:35AM -0800, Vineet Kumar wrote:
> > try
> > 
> > ldd -v /path/to/executable
> > 
> > To see what it's looking for and where.  Then you can use
> > LD_LIBRARY_PATH to override its search path with a righteous one.
> Hey, that is one neat command. Very useful to know that!
> OK. The original error has been solved. Somehow I'd got a symlink to
> the woody libstdc++ but without the actual so being there - this on a
> slink system.
> OK, phoenix has obviously been compiled against newer libs than slink,
> which is not really surprising, but it's been linked dynamic instead
> of static, so its portability has been compromised. So I've given it a
> directory tree with the relevant woody libs in it, and it can now find
> them, but I still get an error:
> libc.so.6: undefined symbol: _dl_initial_searchlist
> I'm guessing that this is because phoenix is trying to use the slink
> dynamic loader (_dl ?), which in turn can't see the results of the chroot
> ldconfig I did in the phoenix directory tree. Indeed, ldd -v reveals
> that it is looking for /lib/ld-linux.so.2, with a full pathname, so
> LD_LIBRARY_PATH isn't gonna touch that.
> The obvious solution is to recompile from source, but the source isn't
> there, the phoenix download page only has the binary - WHAAT??
> I suppose I could expand my 'mini-woody' tree to contain X and all the
> networking stuff, and simply chroot into it to run phoenix. But with
> all that in it, it wouldn't be very 'mini' anymore.
> Is there a more powerful hack than LD_LIBRARY_PATH? Is there a sort of
> 'partial chroot' that can preserve access to specified directories
> outside the chrooted-into tree? Is there a URL from which I can
> download the phoenix source?

execute your ld-linux.so.2 directly. Something like

/path/to/your/chroot/lib/ld-linux.so.2 /path/to/your/executable

(combined with an LD_LIBRARY_PATH hack, so that the ld-linux that you
execute looks for libraries in the directory you specify instead of

good times,

Attachment: pgpPw9XgOCWqE.pgp
Description: PGP signature

Reply to: