[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

still can't get bttv to load (been trying for days..)

Hi list,

After switching from a mono Hauppauge WinTVgo to a WinTV-PCI-FM (model 647) (PAL-B/G 34514 REV
E142) with a Conexant decoder, I can't for the life of me get bttv to load. I've tried it for days

I was convinced that the Conexant decoder is a BT878, but it doesn't actually mention that ON the
chip. It says: CX23881-27

I've tried numerous combinations of first loading/not loading tuner and/or msp3400, different
combinations of the i2c modules, different options the bttv itself and with or without postinstall
action for loading tuner and msp3400.

I assumed that when I say modprobe bttv, it actually checks what the /etc/modules.conf currently
says? (that would affect whether or not option changes get seen...)
As far as the card= option is concerned, I've tried leaving it away and setting it to 10, assuming
a BT878.

I've suspected a PCI problem and have tried different PCI slots and tried with/without Soundcard.
Everything seems to end up Busmaster on IRQ11 anyway. This was the same with the old card and
there it wasn't a problem. From the KDE system info and from scanpci it seems that the card is not
detected in any useful way.

No matter what I do, the feedback on the command line is this:

continuity:~# modprobe bttv
/lib/modules/2.4.18-bf2.4/kernel/drivers/media/video/bttv.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ
/lib/modules/2.4.18-bf2.4/kernel/drivers/media/video/bttv.o: insmod
/lib/modules/2.4.18-bf2.4/kernel/drivers/media/video/bttv.o failed
/lib/modules/2.4.18-bf2.4/kernel/drivers/media/video/bttv.o: insmod bttv failed

and in /var/log/messages:

Dec  6 22:34:43 continuity kernel: Linux video capture interface: v1.00
Dec  6 22:35:13 continuity kernel: bttv: driver version 0.7.83 loaded
Dec  6 22:35:13 continuity kernel: bttv: using 2 buffers with 2080k (4160k total) for capture
Dec  6 22:35:13 continuity kernel: bttv: Host bridge is Intel Corp. 440LX/EX - 82443LX/EX Host
Dec  6 22:35:13 continuity kernel: bttv: Host bridge needs ETBF enabled.

I've seen in examples on the net and with the card I had before that the last remark doesn't have
to mean it won't work. Usually, after that ETBF remark the next line would say: card so-and-so
detected, only on my machine that just doesn't happen.

If the chip is actually not a BT878 but something else, what card= option would I have to set?
Can it be helpful to switch from (Woody) stable to testing or unstable?

Any clues?


.   ***************************************************
    ** lukaslatz@yahoo.com    m. +31 (0) 6  19544439 **
    **                        t. +31 (0) 10 418 2023 **
    ** philips willemstraat 14B2   3051 PP rotterdam **
    **         http://www.bambleweeny.com            **

Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.

Reply to: