[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Re: Realtek NIC and Modem trouble.

Mike Russell said:
> Yes, I disabled both onboard serial ports and the modem is now working
> fine. I got the network driver but it dosnt compile. Ive put up the output
> of the compiling to: http://midgedog.orcon.net.nz/compilelog.txt

do you have the headers installed for your kernel? I don't use the
debian stock kernels myself. So I can't give a whole lot of guidance
on using the kernel-headers-* package. Compiling 3rd party modules
is almost always much more difficult if you don't have your own
kernel compiled and the source in /usr/src/linux (the kernel-headers
package I think is supposed to make it so you don't need it but
like I said I've never used it so I can't say for certain)

Looking at the log makes me think the files you downloaded were
curropted. What did you use to download them? I used wget. Try downloading
it again, using regular ftp if needed. if you downloaded it on a win32
box I would pass it through dos2unix to strip out the CRs from the file
(just makes it cleaner), if that still doesn't work, try this file:


its the files you need, tarred and gzipped so it should be immune from
corruption that may be otherwise hidden. If it is curropted it won't
uncompress, which makes it easy to see a problem.

I ran this command to compile and it went clean:
aphro@shadow:/tmp$ gcc -DMODULE -D__KERNEL__ -O6 -I/usr/src/linux/include
-include /usr/src/linux/include/linux/modversions.h -c rtl8139.c
aphro@shadow:/tmp$ ls -l rt8139.tar.gz
aphro@shadow:/tmp$ ls -l rtl8139.*
-rw-r--r--    1 aphro    aphro       55787 Dec  5 15:45 rtl8139.c
-rw-r--r--    1 aphro    aphro       18044 Dec  5 15:57 rtl8139.o
aphro@shadow:/tmp$ gcc -DMODULE -D__KERNEL__ -O6 -I/usr/src/linux/include
-include /usr/src/linux/include/linux/modversions.h -c pci-scan.c
In file included from pci-scan.c:60:
/usr/src/linux/include/linux/module.h:20: warning: `_set_ver' redefined
/usr/src/linux/include/linux/modsetver.h:9: warning: this is the location of
the previous definition
aphro@shadow:/tmp$ ls -l pci-scan.*
-rw-r--r--    1 aphro    aphro       20187 Dec  5 15:45 pci-scan.c
-rw-r--r--    1 aphro    aphro        2990 Dec  5 15:45 pci-scan.h
-rw-r--r--    1 aphro    aphro        7464 Dec  5 15:58 pci-scan.o

got the command to use here:

I compiled against a home brew 2.4.20 kernel on my thinkpad T20.

good luck!


Reply to: