[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: modprobe is automatically calling ifup/ifconfig. Why?

    "Joe" == Joe Emenaker <joe@emenaker.com> writes:

    Joe> I've been having a problem with my Debian system
    Joe> automatically bringing up my eth0 interface even though I
    Joe> don't have it marked as "auto" in
    Joe> /etc/network/interfaces. Until now, I had figured that it was
    Joe> due to a bug in ifup that brought up all auto *and* all
    Joe> dhcp'd interfaces, but now I've discovered that that isn't
    Joe> the problem.

    Joe> The problem seems to be that, when I run modprobe to load the
    Joe> driver for my ethernet interface, ifup or ifconfig seems to
    Joe> get run as well. Since I have my 3c95x driver in my
    Joe> /etc/modules, it gets loaded at boot time and then the
    Joe> interface actually gets *brought up*. Now, I kinda suspect
    Joe> that it's "ifup" that's getting run because the interface,
    Joe> after it has been brought up, seems to use the contents of
    Joe> /etc/network/interfaces... which is a debianism. However, if
    Joe> ifconfig can save/restore the settings from the last time the
    Joe> interface was brought up, then I guess ifconfig could be
    Joe> what's being run... but I really suspect ifup.

Most likely it is not ifup, but some DHCP client that is being
started. When debian boots, it runs 'ifup -a' (see
/etc/init.d/networking) to bring up things listed as auto. If you
think ifup is at fault, why don't you try 'ifdown' on all your
interfaces, and then 'ifup -a' to see what it does? 

    Joe> So, does anybody know more about this modprobe/ifup
    Joe> relationship? Is there a way to turn it off, or do I need to
    Joe> take 3c59x out of /etc/modules and alias eth0 to it in
    Joe> modules.conf?

There is no such relationship AFAIK that is set up by default. You
certainly should not have to modify /etc/modules as you suggest. 

I suggest you modify your interfaces file so that eth0 is given a
static address with no auto keyword. If you still get a dhcp address
then you can be sure that it is not ifup that is at fault.


Reply to: