Problem with libc6.
I am new to debian, but like to get a router firewall get set up for my home
network, so I started out with a woody install and got the router and
firewall all started, but now I wanted to install snort and I got into some
trouble. If I do an apt-get upgrade I get the following message.
I see the versions don't mach but I couldn't find a solution to my problem ?!
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these.
Sorry, but the following packages have unmet dependencies:
libc6: Depends: libdb1-compat but it is not installable
libc6-dev: Depends: libc6 (= 2.2.5-11.2) but 2.2.5-15 is installed
locales: Depends: glibc-2.2.5-11.2
snort: Depends: libpcap0.7 but it is not installable
Depends: libsnmp4.2 but it is not installed
Depends: snort-rules but it is not installable
Depends: snort-common but it is not installable
E: Unmet dependencies. Try using -f
If I do "dpkg -s libc6|grep Version" I get: