Re: gcc version issues
On Sunday 08 September 2002 21:44, Gib Bogle wrote:
> My Debian system is 2.4.18, which was built with gcc 2.95.4. I want to
> compile some software which apparently requires gcc 2.96 or later. What
> should I do? My first thought was simply to install a later version of
> gcc, but it occurs to me that this could create problems for me later,
> for example if I wanted to rebuild the kernel.
There is no 2.95.6 package in Debian because .6 was never actually released.
It is essentially a back port of parts of the new 3.0 to the 2.95 tree. The
2.95.4 compiler in Debian should work just fine for you. That said, we make
separate package versions of our compilers so you can install them together
or individually. I have 2.95.4, 3.0, 3.1 and 3.1 installed on one of my
machines. The default compiler on woody is 2.95.4 and in unstable we are
moving to 3.2. You can run the others by installing the right package and
invoking it as gcc-version, i.e. gcc-3.2.