[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Mouse Problems in X

Howdy Travis,

* Travis Troyer <degraz@planethalflife.com> [020903 16:14]:
> Thanks to everyone for the suggestions.  I followed what Nick Hastings 
> suggested, and found that when I tried to modprobe usbcore, hid, input,
> or 
> mousedev, that it said they couldn't be located.  I also tried uname -a,
> and 
> got:
> 2.2.20-idepci #1
> Being a newbie, I went to dselect to look for the modules, and noticed
> there 
> were various kernel images there, including mine, for which the
> description 
> said it only contained ide and pci support.  So, I thought that might
> have 
> something to do with it.  I choose the base 2.2.20 kernel image, and 
> installed it, and now my mouse works fine, as did the modprobe of those 
> modules.  

Good stuff!

> The thing is, now my network is inaccessible and I receive
> errors, 
> something along these lines (I'm not in linux right now, and did not
> think 
> to right it down):
> /etc/moldules.conf is newer than ....modules.dep
> It doesn't seem to hurt anything, however.

Hmm... the command update-modules comes to mind... have a look at the
man page.
> Anybody have any idea what I did to my network, and what I can do to fix

Yep, I'm guessing that the module for your ethernet card is not
installed anymore. Do you know what type of card you have? If not try
the command


Among other things it should list your networkcard:
Look for "Ethernet controller:"

 Next, you need to find out what driver that card needs (you can google 
for it). Then install that module with modprobe.

An example:
hastings@zooks ~ 1%  lspci | grep "Ethernet controller"
02:08.0 Ethernet controller: Intel Corporation 82820 820 (Camino 2)
Chipset Ethernet (rev 03)

Then linux  google for "Intel Corporation 82820 820 (Camino 2)"

yeilds eepro100


modprobe eepro100

An alternative is to run modconf, and navigate throught the menus
until you find the correct module (some of them have discriptions).
> this error?  I'm thinking about reinstalling, now that I have learned
> some 
> basics.

Resist the temptation, you'll learn more, by fixing the problem rather
than starting from scratch.



BTW a warning: some of this stuff might not work for your system (which 
I guess is woody) because I don't know what is installed and I don't have any
experience with 2.2 series kernels.

Debian testing/unstable
Linux onefish 2.4.19-lavienx #1 Mon Aug 12 20:29:59 EST 2002
i686 unknown unknown GNU/Linux

Reply to: