[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: /usr/bin/ld: cannot find -lXext

On Mon, Sep 02, 2002 at 10:02:34PM +0530, Dr. Sachin Kale wrote:
> From: Colin Watson <cjwatson@debian.org>
> > On Sun, Sep 01, 2002 at 09:55:02PM +0530, Dr. Sachin Kale wrote:
> > > I am trying to compile examples given in qt2-doc package, even
> > > though the directory containg libs is specified as
> > > -L/usr/X11R6/lib while linking I get the above error.
> >
> > Have you installed xlibs-dev?
> tried to install the said package, it depended on xlibs, so tried to
> install that. But it conflicted with xlibs6g so dpkg -i could not
> install it.

Like I say, xlib6g-dev will solve that.

> Now I have observed that on trying to link the qt2-doc
> example I get /usr/bin/ld: cannot find -lz error instead of -lXext.

Er, so that would be exactly the same kind of thing. When compiling
executables, you need the appropriate -dev packages. In this case,
zlib1g-dev. If you get 'cannot find -lsomething', use the search engine
at http://packages.debian.org/ to search for 'libsomething.a' or
'libsomething.so', and ignore the runtime libraries which are

Colin Watson                                  [cjwatson@flatline.org.uk]

Reply to: