[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problem installing postgreSQL and procps

Hi all!

Yesterday I tried to install postgreSQL. It failed with an error:
Restarting PostgreSQL database: postmaster
No /usr/lib/postgresql/bin/postmaster found running; none killed.
Starting PostgreSQL postmaster.
postmaster successfully started
ps: unknown long option
usage:  ps -acehjlnrsSuvwx{t<tty>|#|O[-]u[-]U..} \
           --help gives you this message
           --version prints version information

The postmaster has not restarted.

So, I started to look in to ps. ps is a part of the procps-package so I
tried to update that package. I couldn't. This time the error was:

Preparing to replace procps 1:2.0.7-4 (using
.../procps_1%3a2.0.7-8_i386.deb) ...
Unpacking replacement procps ...
dpkg: error processing /var/cache/apt/archives/procps_1%3a2.0.7-8_i386.deb
 unable to make backup link of `./bin/ps' before installing new
version: Operation not permitted
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

I even tried to delete /bin/ps manually:

raven:/bin# rm -rf ps
rm: cannot unlink `ps': Operation not permitted

I checked the documentation for ps and found that the option --User was
allowed so I figured that my ps for some reson is f*cked up.

Now I need your help!

* How can I check if there is a link to /bin/ps thats blocking it from

* How can I delete /bin/ps?

* All other ideas.


|-     Ceterum censeo,     -|
|- Microsoft esse delendam -|
|      www.debian.org       |
|     Andreas Andersson     |
|      raven@raven.nu       |
|       icq:18100175        |
|    http://www.raven.nu    |
|  046-157733  070-7572373  |

Reply to: