[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: joystick and devfs?



On Thu, Jul 11, 2002 at 04:00:36PM +0200, Roman Joost wrote:
> Hi..
> 
> I tried to get my old joystick working with my Soundblaster Live Card. I
> compiled the kernel modules (<M> Game port support, <M>   SoundBlaster Live!
> 		gameports, <M>   Classic PC analog joysticks and gamepads).
> 
> Allright.. so good so far. My kernel boots perfect, seems to find my gamepad:
> 
> >input0: Analog 4-axis 4-button joystick at gameport0.0 [TSC timer, 552 MHz clock, 831 ns res]
> >gameport0: Emu10k1 Gameport at 0xdc00 size 8 speed 1242 kHz
> 
> and than, nothing happens. My devfs don't do anything to create the device-nodes
> or something else. What did I wrong? The Modules are loaded into the kernel:
> 
> >emu10k1-gp              1216   0  (unused)
> >analog                  7520   0  (unused)
> >gameport                1548   0  [emu10k1-gp analog]
> >input                   3424   0  [analog]
> 
> Where can i find the device-nodes? Thanks for the ideas...

I had a similar problem (old analog joystick on soundblaster soundcard).
I ended up with this in /etc/modutils/joystick

    alias /dev/joysticks	joydev
    pre-install joydev	modprobe analog && modprobe ns558

which gives me /dev/js0 to use.

The important bit (for me) turned out to be ns558 (standard IBM game
port driver). In total I end up with these modules loaded
(kernel=2.4.18):
    joydev
    ns558
    analog
    gameport
Apparantly the order matters; I tried rmmod'ing ns558 (as it is
allegedly not in use), but that breaks things. rmmod'ing the rest
following by referencing /dev/js0 gets things going again.

Hope this helps. Your mileage may vary.

-- 
Karl E. Jørgensen
karl@jorgensen.com
www.karl.jorgensen.com
==== Today's fortune:
"... And remember: if you don't like the news, go out and make some of
your own."
        	-- "Scoop" Nisker, KFOG radio reporter Preposterous Words

Attachment: pgpJuHEsZdo20.pgp
Description: PGP signature


Reply to: