[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Help switching from lilo to grub



jennyw wrote:
>
> On Sat, Jul 13, 2002 at 03:41:42AM +0000, Jason Lunz
> wrote:
>
>> isn't it "grub-install /dev/hda" or what have you?
>
>
> Yep!
>
> The first time I tried "grub-install /dev/hda1" which
> might have been a problem.  The next time I did
> "grub-install /dev/hda" and my system is now booting
> using grub!
>

That's good to hear... but hopefully /dev/hda1 *isn't* a
Windows partition - because if it is that step would have
made it temporarily unbootable :( (or :) depending on your
point of view...). At any rate, for what it is worth, you
have actually now got grub installed in two places - in the
mbr of your harddisk and in the boot sector of your first
partition but it is obviously the one in the mbr that you
are seeing. If you were to use a DOS boot disk and run
'fdisk /mbr' you  would in fact still be able to boot linux
using grub, this time from the copy installed in the boot
sector of hda1 as 'fdisk /mbr' installs a sort of primitive
chainloader that simply defers the boot process from the mbr
to the boot sector of hda1 (or what DOS calls "C:") - from
what I have been able to tell, at any rate.


--
David P. James
Ottawa, Ontario
http://members.rogers.com/dpjames/

The bureaucratic mentality is the only constant in the universe.
-Dr. Leonard McCoy, Star Trek IV


--
To UNSUBSCRIBE, email to debian-user-request@lists.debian.org with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org



Reply to: