[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Solved but some Qs remain WAS: Re: PCI IDE controller - how to make it work?

Jerome Acks Jr wrote:
> On Wed, Apr 24, 2002 at 12:59:07PM -0700, Erik Steffl wrote:
> >   I just got PCI IDE controller and have troubles making it work with
> > linux (2.4.18).
> >
> >   the docs in linux/Documentation/ide.txt say that linux will probe for
> > ide devices that have device files in /dev or that I can force it to
> > probe using ide2=0x1e8,0x3ee,11 (kernel option). So I thought it should
> > almost work by itself but it doesn't. Here's what I did:
> >
> >   in /etc/lilo.conf, I tried these (and some other) variations:
> >
> > append  = "ide2=0x1e8,0x3ee,11 ide3=0x168,0x36e,11 hdg=cdrom"
> > append  = "ide2=0x1e8,0x3ee,11 ide3=0x168,0x36e"
> > append  = "ide2=0x1e8,0x3ee ide3=0x168,0x36e"
> Just some guessing:
> From below it looks like hardware probing is finding something.
> Maybe try mounting devfs on /dev and then use devfs naming
> conventions to access the new ide devices rather than specifying ports
> in append.

  I was trying various things and what finally helped was specifying the
addresses from /proc/ioports in append line:

  this is what linux thinks it has (from /proc/ioports):

cc00-cc07 : Artop Electronic Corp ATP865
d000-d003 : Artop Electronic Corp ATP865
d400-d407 : Artop Electronic Corp ATP865
d800-d803 : Artop Electronic Corp ATP865
dc00-dc0f : Artop Electronic Corp ATP865

  and this is append line from /etc/lilo.conf that worked:

append  = "ide2=0xcc00,0xd000 ide3=0xd400,0xd800"

  what I don't understand why would linux find it out (without any
append line), after all it found the device, the ioports, why doesn't it
use it?

  could it be related that it thinks it's scsi storage device? from
lspci output:

00:09.0 SCSI storage controller: Artop Electronic Corp: Unknown device
0009 (rev 02)

  yet it works as IDE...

  (yes, I know I should use ide-scsi for most work with cd burner but
still, lspci doesn't have anything to do with drivers - why does it
think it's scsi device?)

> [snip]
> >
> >   When I connect everything to PCI controller and disable the ide on
> > motherboard the computer starts booting, the disks show just like they
> > should (hda, hdb for HD, hdc for cdrom), the lilo boots kernel but for
> > some reason kernel doesn't want to mount root file system, it's excuse
> > being that root device 304 was  not found... what does that mean? I
> This is saying it can't find the root device on ide0.
> If you switch your hardware from ide0 to new PCI controller, I thing
> you will need to reconfigure lilo to boot from that device or at least
> rerun lilo.

  lilo booted ok, it's just that kernel couldn't find root file system
(device 304). since I disabled internal ide the pci board became ide0
and ide1, lilo even booted properly... ???



To UNSUBSCRIBE, email to debian-user-request@lists.debian.org 
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: