[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Setting up ntl cable modem/DHCP?

Not sure if this will help but anyway :-)

I had a similar problem at work where by my desktop PC running Debian couldn't get an IP address from the DHCP server (which was a M$ NT server). Other windows machines (including my desktop when booted into windows) could. However this only happened if I was on a different subnet to the DHCP server - if I was on the same subnet the Debian box got an IP every time without a hitch.

The way I solved this was to install the dhcp-relay package on the debnian box which simply forwards any DHCP offers to a specific IP address.

As it works perfectly this way I have never bothered to find out what the problem was.

Like I said not sure if this would work in your case.

I'd be interested in knowing when you get it working though as I considering NTL broadband jobby aswell, although I not going back to windows just to use a faster connection :-)


Jason Chambers (jason.chambers@ntlworld.com)
Leicester, England

james@soon.co.uk wrote:

I think I could be tantalisingly close to getting a cable modem up and
running with my Debian box (Woody on a Compaq Professional Workstation
5000 PPro SMP) if I could just get my DHCP client to talk to my cable
operator's DHCP server.

The story so far:

*Cable Modem side - My cable operator is ntl (England, SE London/Kent)
I know that the line in to my home, the set top box (Pace DITV-1000
Phase 1b) and the cat5 UTP (crossover) cable to my Debian box is
working. This is because an ntl installation technician has connected
to the service using his laptop. When I have tried to connect my
Debian box I know the service is available because of the info on the
"user information" screen I can display on my TV.

*My Debian Box - I believe that my Ethernet card is set-up OK because
when using "dmesg | more" I can find:

ThunderLAN driver v1.14a
TLAN: eth0 irq=20, io=1400,
Compaq Netelligent Integrated 10/100 TX UTP, Rev. 16
TLAN: 1 device installed, PCI: 1 EISA: 0

Also when I run "ifconfig" I get:

Link encap:Ethernet HWaddr 00:80:5F:C1:55:40 UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:27288 errors:8 dropped:0 overruns:0 frame:8
TX packets:35281 errors:26 dropped:0 overruns:0 carrier:26
collisions:1536 txqueuelen:100 RX bytes:3840126 (3.6 MiB) TX bytes:3130668 (2.9 MiB) Interrupt:20 Base address:0x1400 lo Link encap:Local Loopback UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:9195 errors:0 dropped:0 overruns:0 frame:0
TX packets:9195 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0 RX bytes:3010625 (2.8 MiB) TX bytes:3010625 (2.8 MiB)

For what its worth I am also getting a solid green and flashing amber
LEDs on the card, unfortunately I don't have a home network or other
Ethernets devices I can use to test it.

The DHCP client software I am using is chcp3-client v3.0+3.0.1r when I
run the "dhclient" command I get the following:

Listening on LPF/eth0/00:80:5f:c1:55:40
Sending on   LPF/eth0/00:80:5f:c1:55:40
Listening on LPF/lo/
Sending on   LPF/lo/
Sending on   Socket/fallback
DHCPDISCOVER on lo to port 67 interval 4
DHCPDISCOVER on eth0 to port 67 interval 3
DHCPDISCOVER on lo to port 67 interval 8
DHCPDISCOVER on eth0 to port 67 interval 4
DHCPDISCOVER on eth0 to port 67 interval 11
DHCPDISCOVER on lo to port 67 interval 10
DHCPDISCOVER on eth0 to port 67 interval 12
DHCPDISCOVER on lo to port 67 interval 21
DHCPDISCOVER on eth0 to port 67 interval 11
DHCPDISCOVER on eth0 to port 67 interval 9
DHCPDISCOVER on lo to port 67 interval 12
DHCPDISCOVER on eth0 to port 67 interval 11
DHCPDISCOVER on lo to port 67 interval 6
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

Tried the "dhclient -s" option on the two ntl DNS address' listed in
"DHCP mini-HOWTO" and the "STB IP addr" of my box but still no joy.

Ntl do not officially support Linux and getting any form of in-depth
technical information out of them is almost impossible. But the "DHCP
mini-HOWTO" and anecdotal evidence from a conversation with the ntl
installation technician (unfortunately he don't know how) indicate that
a Linux box can be connected.

I would be very grateful if anyone could give me some pointers as to
what I am missing or getting wrong.

Thanks in advance


Personalised email by http://another.com

To UNSUBSCRIBE, email to debian-user-request@lists.debian.org with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: